Mit einem AAAA Resource Record („quad-A“) wird einem DNS-Namen eine IPv6-Adresse zugeordnet. Es handelt sich damit um die IPv6-Entsprechung zum A Resource Record.
Die ursprüngliche Einführung des Record-Typs erfolgte 1995 in RFC1886. RFC2874 definierte 2000 einen neuen Recordtyp A6, der AAAA ablösen sollte. Dieser Standard wurde 2003 von der IETF jedoch auf „experimental“ (experimentell) zurückgestuft und mit RFC3596 AAAA wieder zum zu verwendenden Resource-Record-Typ erhoben.
Gemäß RFC3484 fragen Dual-Stack-IPv6/IPv4-Implementationen zur Namensauflösung stets zunächst nach dem AAAA Resource Record, um im Falle der Nichtexistenz auf den A Resource Record zurückzufallen.
Aufbau
Name
veröffentlichter Name
TTL
time to live: gibt an, wie lange in Sekunden dieser Resource Record in einem Cache gültig sein darf (optional; ohne Angabe wird ein zuvor explizit – per $TTL-Anweisung am Anfang der Zonendatei – definierter Standardwert angenommen)
IN
class: Internet (optional; Alternativen sind die Klassen HS für HESIOD und CH für CHAOS, zwei seit langem obsolete, experimentelle Netzwerkprojekte; ohne Angabe wird IN angenommen)
AAAA
Record Type
Adresse
die IPv6-Adresse, unter der der gesuchte Server erreichbar ist