Según The Jargon Dictionary, el humor hacker es aquel que comparten los expertos en computadoras (en particular, los hackers), que incluye cosas como parodias elaboradas de documentos como especificaciones, estándares, descripciones de lenguajes, etc.
Los RFC documentan todos los protocolos estandarizados de Internet y son la fuente de referencias para implementar alguna aplicación o para conocer los detalles de algún protocolo, por tal razón el tratamiento y lenguaje de los documentos es sumamente formal, salvo por algunas excepciones: el 1 de abril (April Fool's day) anglosajón es algo parecido al Día de los Santos Inocentes hispanoamericano (28 de diciembre). En ese talante, los RFCs publicados el 1 de abril suelen ser bromas ingeniosas para provocar la hilaridad de los entendidos.
Listado de RFCs de broma
RFC 8369: Internationalizing IPv6 Using 128-Bit Unicode
RFC 8367: Wrongful Termination of Internet Protocol (IP) Packets
RFC 8140: The Arte of ASCII: Or, An True and Accurate Representation of an Menagerie of Thynges Fabulous and Wonderful in Ye Forme of Character