Simple Authentication and Security Layer

A Simple Authentication and Security Layer (SASL) egy autentikációs és adatbiztonsági szoftverfejlesztési keretrendszer internetes protokollok számára. Szétválasztja az azonosítási mechanizmusokat az alkalmazásprotokolloktól, elméletben bármilyen SASL által támogatott azonosítási mechanizmust elérhetővé tesz SASL-t használó alkalmazásokban.

Az autentikációs mechanizmusok a proxy autentikációt is támogatják, ami egy felhasználónak lehetőséget ad egy másik felhasználó szerepének betöltésére. Adatbiztonsági réteget is tartalmaz, ezzel adatintegritási és adatbizalmi szolgáltatásokat nyújt.

Például a DIGEST-MD5 eljárás egy olyan mechanizmus, amely adatbiztonsági réteggel hoz létre. A SASL-képes alkalmazások tipikusan támogatják a Transport Layer Security (TLS) protokollt is.

1997-ben John Gardiner Myers a Carnegie Mellon egyetemen írta meg az eredeti SASL specifikációt (RFC 2222). 2006-ban ezt a dokumentumot felváltotta a RFC 4422, amelyet Alexey Melnikov és Kurt Zeilenga írtak.

A SASL egy IETF Standard Track protokoll, 2010-től a Proposed Standard szabványcsoportba tartozik.

SASL mechanizmusok

Egy SASL mechanizmus kérések és válaszok sorozatát implementálja. A következő SASL mechanizmusok definiáltak:

A GS2 mechanizmus-család támogat tetszőleges GSS-API mechanizmusokat SASL-ben. Jelenleg szabványosítva van, RFC 5801.

SASL-képes alkalmazásprotokollok

Alkalmazás protokollok a SASL kommunikációs reprezentációjukat profilokkal definiálják. Egy protokollnak van egy szolgáltatás neve (pl. "ldap") egy közös tárban [[Generic Security Services Application Program Interface|GSSAPI]] és Kerberos. szolgáltatásokkal.

2010-ben a SASL-t támogató protokollok közé tartoznak:

Lásd még

Külső hivatkozások

Fordítás

Jegyzetek

  1. ↑ SASL mechanisms
  2. ↑ Simon Josefsson. "Using GSS-API Mechanisms in SASL: The GS2 Mechanism Family".
  3. ↑ GSSAPI/Kerberos/SASL Service names
  4. ↑ Bartlett, Andrew (2005. április 25.). "GENSEC - Designing a security subsystem" (PDF). 4. o. Hozzáférés: 2010. március 28.. The idea of a generic security API is not new [...] to implement, by some mechanism or other, a wide variety of these protocols, including SASL, GSS-API, SPNEGO as well as the proprietary NTLMSSP [...] in the wider open source world we see individual applications introduce similar abstraction layers, or adopt the Open Source Cyrus-SASL library to provide one. {{cite web}}: More than one of |pages= és |page= specified (súgó)