Tipi di record DNS

Questo elenco di tipi di record DNS consente di orientarsi facilmente fra i vari tipi di record usati dal DNS.

Record DNS normalmente in uso

Codice Numero ID RFC di riferimento Descrizione Funzione
A 1 1035 Record di indirizzoRestituisce un indirizzo IPv4 a 32 bit, normalmente usato per collegare un nome host al suo indirizzo IP.
AAAA 28 3596 Record di indirizzo IPv6Restituisce un indirizzo IPv6 a 128 bit, normalmente usato per collegare un nome host al suo indirizzo IPv6.
AFSDB 18 1183 Record del database AFS Puntamento al server di database AFS. Questo record è usato dai client AFS per contattare un server AFS fuori dal proprio dominio. Un sottotipo di questo record era usato dall'obsoleto file system DCE/DFS.
AXFR 252 1035 Trasferimento dell'intera zona Richiesta di trasferimento dell'intera zona dal server principale ad un secondario.
CERT374398Record di certificatoTrasferisce un certificato di tipo PKIX, SPKI, PGP, ecc.
CNAME 5 1035 Record di nome canonicoPermette di collegare un nome DNS ad un altro. La risoluzione continuerà con il nuovo nome indicato dal record CNAME. Questa funzione è molto utile quando, ad esempio, sullo stesso server sono disponibili più servizi come FTP, HTTP, ecc. operanti su porte differenti. Ciascun servizio potrà avere il suo riferimento DNS (ad esempio ftp.example.com. e www.example.com.). È molto utile anche quando sullo stesso server ci sono più istanze web con differenti nomi ma usando lo stesso indirizzo. Questa funzione richiede, però, il supporto da parte del server di identità multiple con riconoscimento dell'intestazione HTTP.
DHCID494701Identificazione DHCPUsato in congiunzione con un record FQDN restituisce informazioni sul server DHCP.
DLV327694431Record per la validazione DNSSECUsato per pubblicare un puntatore a un certificato DNSSEC fuori dalla catena di delegazione.
DNAME 39 2672 Nome di delegazione Opera in modo simile al record CNAME ma invece di far riferimento ad un singolo nome fa riferimento ad una porzione di albero DNS sotto un nuovo nome. Analogamente a CNAME la risoluzione continuerà con il nuovo nome.
DNSKEY483755Record chiave DNSIl record chiave usato in DNSSEC.
DS433658Delegazione del firmatarioUsato per identificare la chiave di firma DNSSEC per una zona delegata.
HIP555205Host Identity ProtocolUn protocollo che consente di aumentare la sicurezza separando gli indirizzi IP degli host.
IPSECKEY454025Chiave IPsecUsato per trasferire informazioni IPsec.
IXFR2511995Trasferimento di zona incrementaleTrasferisce la porzione di zona che è stata cambiata dal server DND principale ad un secondario.
KEY254034Record chiaveUsato solo per TKEY (RFC 2930). Prima che fosse pubblicata l'RFC 3755 era anche usato per DNSSEC, attualmente DNSSEC usa DNSKEY.
LOC291876Record di localizzazioneAssocia una localizzazione geografica ad un nome DNS.
MX151035Server di posta Collega un nome di dominio ad una lista di server di posta autorevoli per quel dominio. I record indicano anche la preferenza di un server rispetto ad un altro.
NAPTR353403Naming Authority PointerUn nuovo tipo di record DNS che supporta l'indirizzamento usando espressioni regolari.
NS21035Riferimento ai server DNSDelega una zona DNS ad essere gestita da un server DNS autorevole per quel nome di dominio.
NSEC473755Record Next-SecureUsato da DNSSEC per stabilire se un nome non esiste.
NSEC3505155Record NSEC versione 3Usato da DNSSEC.
NSEC3PARAM515155Parametri NSEC3Parametri del record NSEC3.
OPT412671OptionPseudo record DNS necessario per supportare EDNS.
PTR121035Record puntatore Puntatore ad un nome canonico usato per la risoluzione DNS inversa. Inserendo un record PTR per un nome canonico di dominio nella zona in-addr.arpa. (ip6.arpa. nel caso di IPv6) fa sì che si possa risalire al nome host dal suo indirizzo IP.
RRSIG463755Firma DNSSECFirma per una serie di record DNSSEC sicuri.
SIG242535FirmaRecord di firma usato in SIG(0) (RFC 2931). Prima che fosse pubblicata l'RFC 3755 era anche usato per DNSSEC, attualmente DNSSEC usa RRSIG.
SOA61035Record di start of authority Restituisce informazioni autorevoli sulla zona DNS, incluso il server DNS principale, l'e-mail dell'amministratore, il numero seriale del dominio (utile per sapere se i dati della zona sono stati variati) e diversi timer che regolano la frequenza di trasferimento e la durata di validità dei record.
SPF994408Record SPFSpecifica dati relativi al protocollo SPF. Deprecato come uso diretto (99) - Alternativa questi dati vengono inseriti in un record TXT.
SRV332782Localizzatore di servizi Un servizio generalizzato di ricerca di servizi molto utile per nuovi protocolli per non dover aggiungere tipi di record specializzati come ad esempio il record MX.
SSHFP444255Impronta della chiave pubblica SSH Pubblica la chiave pubblica dell'host SSH sul DNS, in modo da aiutare la verifica dell'autenticità dell'host.
TA32768NessunaCertificazione DNSSECParte della proposta DNSSEC senza una radice DNS firmata.
TKEY2492930Chiave di transazione Supporta un metodo per rendere sicuro il DNS. Implementa la sicurezza fra il server DNS che risolve la richiesta e il server autorevole di zona. DNSSEC, al contrario, rende sicuri i singoli record.
TSIG2502845Firma di transazioneSupporta un insieme di meccanismi di sicurezza del DNS. Implementa la sicurezza fra il server DNS che risolve la richiesta e il server autorevole di zona. DNSSEC, al contrario, rende sicuri i singoli record.
TXT161035Record di testo Era stato pensato per aggiungere commenti leggibili ad un record DNS. Dall'inizio degli anni novanta, invece, è usato per trasferire informazioni di sicurezza in accordo alla RFC 1464, opportunistic encryption, Sender Policy Framework e DomainKeys. Il sistema di DNS dinamico del server DHCP ISC usa campi di testo nelle zone dinamiche per identificare i record modificati dal server DHCP.

Altri tipi di record

Il tipo di record 255 è riservato e significa "qualsiasi record". In nslookup scrivere type=all significa porre a 255 il campo tipo e richiedere quindi il trasferimento di qualsiasi tipo di record corrispondente alla risoluzione richiesta.

Ci sono poi altri tipi di record non normalmente usati e qui suddivisi per categoria di non uso.

Note

  1. 1 2 3 4 5 6 7 8 (EN) RFC 1035 — Domain names - implementation and specification, su datatracker.ietf.org, Internet Engineering Task Force.
  2. ↑ (EN) RFC 3596 — DNS Extensions to Support IP Version 6, su datatracker.ietf.org, Internet Engineering Task Force.
  3. ↑ (EN) RFC 1183 — New DNS RR Definitions, su datatracker.ietf.org, Internet Engineering Task Force.
  4. ↑ (EN) RFC 4398 — Storing Certificates in the Domain Name System (DNS), su datatracker.ietf.org, Internet Engineering Task Force.
  5. ↑ (EN) RFC 4701 — A DNS Resource Record (RR) for Encoding Dynamic Host Configuration Protocol (DHCP) Information (DHCID RR), su datatracker.ietf.org, Internet Engineering Task Force.
  6. ↑ (EN) RFC 4431 — The DNSSEC Lookaside Validation (DLV) DNS Resource Record, su datatracker.ietf.org, Internet Engineering Task Force.
  7. ↑ (EN) RFC 2672 — Non-Terminal DNS Name Redirection, su datatracker.ietf.org, Internet Engineering Task Force.
  8. 1 2 3 (EN) RFC 3755 — Legacy Resolver Compatibility for Delegation Signer (DS), su datatracker.ietf.org, Internet Engineering Task Force.
  9. ↑ (EN) RFC 3658 — Delegation Signer (DS) Resource Record (RR), su datatracker.ietf.org, Internet Engineering Task Force.
  10. ↑ (EN) RFC 5205 — Host Identity Protocol (HIP) Domain Name System (DNS) Extension, su datatracker.ietf.org, Internet Engineering Task Force.
  11. ↑ (EN) RFC 4025 — A Method for Storing IPsec Keying Material in DNS, su datatracker.ietf.org, Internet Engineering Task Force.
  12. ↑ (EN) RFC 1995 — Incremental Zone Transfer in DNS, su datatracker.ietf.org, Internet Engineering Task Force.
  13. ↑ (EN) RFC 4034 — Resource Records for the DNS Security Extensions, su datatracker.ietf.org, Internet Engineering Task Force.
  14. ↑ (EN) RFC 1876 — A Means for Expressing Location Information in the Domain Name System, su datatracker.ietf.org, Internet Engineering Task Force.
  15. ↑ (EN) RFC 3403 — Dynamic Delegation Discovery System (DDDS) Part Three: The Domain Name System (DNS) Database), su datatracker.ietf.org, Internet Engineering Task Force.
  16. 1 2 (EN) RFC 5155 — DNS Security (DNSSEC) Hashed Authenticated Denial of Existence, su datatracker.ietf.org, Internet Engineering Task Force.
  17. ↑ (EN) RFC 2671 — Extension Mechanisms for DNS (EDNS0), su datatracker.ietf.org, Internet Engineering Task Force.
  18. ↑ (EN) RFC 2535 — Domain Name System Security Extensions, su datatracker.ietf.org, Internet Engineering Task Force.
  19. ↑ (EN) RFC 4408 — Sender Policy Framework (SPF) for Authorizing Use of Domains in E-Mail, Version 1, su datatracker.ietf.org, Internet Engineering Task Force.
  20. ↑ (EN) RFC 2782 — A DNS RR for specifying the location of services (DNS SRV), su datatracker.ietf.org, Internet Engineering Task Force.
  21. ↑ (EN) RFC 4255 — Using DNS to Securely Publish Secure Shell (SSH) Key Fingerprints, su datatracker.ietf.org, Internet Engineering Task Force.
  22. ↑ (EN) Proposta DNSSEC senza una radice DNS firmata (PDF), su watson.org.
  23. ↑ (EN) RFC 2930 — Secret Key Establishment for DNS (TKEY RR), su datatracker.ietf.org, Internet Engineering Task Force.
  24. ↑ (EN) RFC 2845 — Secret Key Transaction Authentication for DNS (TSIG), su datatracker.ietf.org, Internet Engineering Task Force.

Bibliografia

Voci correlate

Collegamenti esterni

  Portale Telematica: accedi alle voci di Wikipedia che parlano di reti, telecomunicazioni e protocolli di rete