Integrated services (usługi zintegrowane, w skrócie: IntServ) – jeden z mechanizmów zapewniających jakość usług (ang. quality of service).
Zdefiniowała go w 1997 grupa robocza IETF Integrated Service w celu optymalizacji QoS.
Cechy architektury IntServ:
- W architekturze IntServ (RFC 1633 ↓) zakłada się, że zasoby w sieci są rezerwowane dla poszczególnych lub zagregowanych strumieni danych. W tym celu został zdefiniowany specjalny protokół sygnalizacyjny znany pod nazwą protokołu RSVP (Reservation Protocol) (RFC 2205 ↓, RFC 2210 ↓), który umożliwia realizację żądania przez daną aplikację rezerwacji zasobów w sieci.
- Implementacja tego protokołu jest wymagana w każdym ruterze IP. W konsekwencji, ruter IP będzie przyjmował i realizował żądania rezerwacji, co wiąże się z przechowywaniem informacji o każdej poczynionej rezerwacji wraz z informacją o skojarzonym strumieniu danych.
W architekturze IntServ zdefiniowano, oprócz standardowej usługi typu Best Effort, dwie dodatkowe usługi:
- Guaranteed Service (RFC 2212 ↓) – przeznaczoną dla aplikacji wymagających gwarancji odnośnie do parametrów jakości przekazu danych związanych z opóźnieniami,
- Controlled-load Service (RFC 2211 ↓) – przeznaczoną dla aplikacji wymagających bezstratnego przekazu danych i charakteryzującą się jakością przekazu określaną jako lepszą niż Best Effort.