Retransmisja

Retransmisja – ponowne przesyłanie pakietów telekomunikacyjnych, które zostały uszkodzone lub utracone. Termin ten odnosi się do jednego z podstawowych mechanizmów stosowanych przez protokoły komunikacyjne, które działają na komutacji pakietów sieci komputerowej w celu zapewnienia niezawodnej łączności (np. takiej, która zapewnia niezawodny strumień bajtów, np. Transmission Control Protocol (TCP)).

Sieci te są zazwyczaj „niewiarygodne”, co oznacza, że może dojść do opóźnień, uszkodzenia lub stracenia pakietów, lub dostarczenia ich z opóźnieniem. Protokoły, które zapewniają niezawodną komunikację w tego typu sieciach, używają kombinację potwierdzeń (ang. acknowledgements), retransmisji brakujących i/lub uszkodzonych pakietów (zazwyczaj inicjowanej przez tzw. timeout) oraz sum kontrolnych w celu zapewnienia wiarygodności.

Potwierdzenia

Istnieje kilka rodzajów potwierdzeń, które mogą być używane samodzielnie lub w połączeniu z protokołami sieciowymi:

Retransmisja

Retransmisja jest bardzo prostym pojęciem. Zawsze, gdy jedna strona wysyła coś do drugiej strony, zachowuje kopię danych, do czasu, kiedy odbiorca potwierdzi, że je otrzymał. W wielu przypadkach nadawca automatycznie retransmituje dane przy użyciu zatrzymanych kopii. Przykładami takich przypadków są sytuacje, gdy:

Zobacz też

Bibliografia

Przypisy

  1. ↑ RFC 793
  2. ↑ RFC 4077
  3. ↑ RFC 2018
  4. ↑ RFC 2488