Management information base

Management information base (MIB), em português base de informações de gerenciamento, é um banco de dados usado para gerenciamento de entidades em uma rede de comunicação. Mais frequentemente associada com o Simple Network Management Protocol (SNMP), o termo também é usado mais genericamente em contextos como no modelo de gerenciamento de rede OSI/ISO. Uma vez que sua intenção é de referir-se à coleção completa de informação de gerenciamento disponível em uma entidade, ele é frequentemente utilizado para se referir a um subconjunto particular, mais corretamente referenciado como módulo MIB.

Objetos no MIB são definidos usando um subconjunto da Abstract Syntax Notation One (ASN.1), em português Notação de Sintaxe Abstrata Um, chamada "Structure of Management Information Version 2 (SMIv2)" RFC 2578, em português Estrutura de Informação de Gerenciamento Versão 2.

O banco de dados é hierárquico (estruturado em árvore) e cada entrada é endereçada através de um identificador de objeto. Os RFCs de documentação na Internet discutem os MIBs, notavelmente o RFC 1155, "Estrutura e Identificação de Informação de Gerenciamento para redes baseadas no TCP/IP", e seus dois complementares, RFC 1213, 'Base de Informações de Gerenciamento para Gerenciamento de Redes baseadas no TCP/IP" e RFC 1157, "Um Protocolo Simples de Gerenciamento de Rede".

Referências

Ícone de esboço Este artigo sobre redes de computadores é um esboço. Você pode ajudar a Wikipédia expandindo-o.