Sanal devre

Bir sanal devre (VC), verileri, bu verilerin kaynak ve hedef uç sistemleri arasında özel bir fiziksel bağlantı varmış gibi görünecek şekilde, paket anahtarlamalı bir ağ üzerinden taşımanın bir yoludur. Sanal devre terimi, sanal bağlantı ile eş anlamlıdır.

Bir bağlantı veya sanal devre kullanılmadan önce, çağrı kurulumu aracılığıyla iki veya daha fazla düğüm veya yazılım uygulama arasında kurulmalıdır. Bundan sonra, düğümler arasında bir bit akışı veya bayt akışı iletilebilir. Bu nedenle, bir sanal devre protokolü, verilerin protokol veri birimlerine bölünmesiyle uğraşmaktan kaçınarak daha yüksek seviyeli protokollere izin vermektedir.

Hepsi olmasa da birçok sanal devre protokolü, hata tespiti ve otomatik tekrar talebi (ARQ) tarafından başlatılan veriyi yeniden iletimlerinin kullanımı yoluyla güvenilir iletişim hizmeti sağlamaktadır.

Sanal devreye alternatif bir ağ konfigürasyonu datagramdır.

Devre anahtarlama ile karşılaştırma

Sanal devre iletişimi devre anahtarlamaya benzer, çünkü her ikisi de bağlantıya yöneliktir, yani her iki durumda da veriler doğru sırayla teslim edilir ve bağlantı kurma aşamasında sinyalleme yükü gereklidir. Bununla birlikte, devre anahtarlama sabit bir bit hızı ve gecikme sağlarken, bunlar aşağıdaki gibi faktörler nedeniyle sanal devre hizmetinde değişebilir:

Sanal arama özelliği

Telekomünikasyonda, bazen sanal arama tesisi olarak adlandırılan sanal arama özelliği, aşağıdakileri içeren bir hizmet özelliğidir:

Sanal çağrılara alternatif bir ağ yapılandırması, datagramları kullanan bağlantısız iletişimdir.

Katman 4 sanal devreler

TCP gibi bağlantı yönelimli taşıma katmanı protokolleri, IP gibi, farklı paketlerin farklı yollar üzerinden yönlendirilebildiği ve bu nedenle sıra dışı teslim edilebildiği, bağlantısız bir paket anahtarlamalı ağ katmanı protokolüne dayanabilmektedir. Ancak TCP'yi sanal bir devre olarak kullanmak mümkündür, çünkü TCP, sipariş dışı teslimatı karşılamak için alıcı tarafında yeniden sıralamaya izin veren segment numaralandırmayı içermektedir.

Katman 2/3 sanal devreler

Veri bağlantısı katmanı ve ağ katmanı sanal devre protokolleri, bağlantı yönelimli paket anahtarlamaya dayanmaktadır; bu, verilerin her zaman aynı ağ yolu boyunca, yani aynı düğümler aracılığıyla iletildiği anlamına gelmektedir. Bunun bağlantısız paket anahtarlamaya göre avantajları şunlardır:

Örnek protokoller

Sanal devre sağlayan taşıma katmanı protokollerine örnekler:

Verilerin her zaman aynı yol üzerinden teslim edildiği ağ katmanı ve veri bağlantısı katmanı sanal devre protokollerine örnekler:

Ayrıca bakınız

Kaynakça

  1. 1 2 Andrew S. Tanenbaum, David J. Wetherall (2011, Fifth Edition. International Edition), "Computer Networks". page 361 978-0-13-255317-9
  2. ↑ RFC 793
  3. 1 2 RFC 1180
  4. ↑ RFC 955
  5. ↑ RFC 1644
  6. ↑ ITU-T, B-ISDN ATM Adaptation Layer specification: Type 3/4 AAL, Recommendation I.363.3 (08/96), International Telecommunication Union, 1996, p5.
  7. ↑ ITU-T, B-ISDN ATM Adaptation Layer specification: Type 5 AAL, Recommendation I.363.5 (08/96), International Telecommunication Union, 1996, p5.