6LoWPAN

6LoWPAN (IPv6 over Low-Power Wireless Personal Area Networks) was a working group of the Internet Engineering Task Force (IETF). It was created with the intention of applying Internet Protocol Version 6 (IPv6) even to the smallest devices, enabling low-power devices with limited processing capabilities to participate in the Internet of Things.

The 6LoWPAN group defined encapsulation, header compression, neighbor discovery and other mechanisms that allow IPv6 to operate over IEEE 802.15.4 based networks. Although IPv4 and IPv6 protocols do not generally care about the physical and MAC layers they operate over, the low-power devices and small packet size defined by IEEE 802.15.4 make it desirable to adapt to these layers.

The base specification developed by the 6LoWPAN IETF group is RFC 4944 (updated by RFC 6282 with header compression, RFC 6775 with neighbor discovery optimization, RFC 8931 with selective fragment recovery and with smaller changes in RFC 8025 and RFC 8066). The problem statement document is RFC 4919. IPv6 over Bluetooth Low Energy using 6LoWPAN techniques is described in RFC 7668.

Application areas

The targets for IPv6 networking for low-power radio communication are devices that need Wireless connectivity to many other devices at lower data rates for devices with very limited power consumption. The header compression mechanisms in RFC 6282 are used to allow IPv6 packets to travel over such networks.

IPv6 is also in use on the smart grid enabling smart meters and other devices to build a micro mesh network before sending the data back to the billing system using the IPv6 backbone. Some of these networks run over IEEE 802.15.4 radios, and therefore use the header compression and fragmentation as specified by RFC6282.[citation needed]

Thread

Thread is a standard from a group of more than fifty companies for a protocol running over 6LoWPAN to enable home automation. The specification is available at no cost as of 24 June 2022, but paid membership is required to implement the protocol. Version 1.0 of the specification was published on 2015-10-29. The protocol most directly competes with Z-Wave and Zigbee IP. In IoT device communications using the Matter standard, Thread is one of two possible wireless transport layers.

Functions

As with all link-layer mappings of IP, RFC4944 provides a number of functions. Beyond the usual differences between L2 and L3 networks, mapping from the IPv6 network to the IEEE 802.15.4 network poses additional design challenges (see RFC 4919 for an overview).

Adapting the packet sizes of the two networks

IPv6 requires the link maximum transmission unit (MTU) to be at least 1280 octets. In contrast, IEEE 802.15.4's standard frame size is 127 octets. A maximum frame overhead of 25 octets and an optional but highly recommended security feature at the link layer poses an additional overhead of up to 21 octets are for AES-CCM-128. This leaves only 81 octets for the upper layers. Since this is so much less than 1280, 6LoWPAN defines a fragmentation and reassembly layer. Further, the standard IPv6 Header is 40 octets long, so header compression is defined as well.

Address resolution

IPv6 nodes are assigned 128 bit IP addresses in a hierarchical manner, through an arbitrary length network prefix. IEEE 802.15.4 devices may use either of IEEE 64 bit extended addresses or, after an association event, 16 bit addresses that are unique within a PAN. There is also a PAN-ID for a group of physically collocated IEEE 802.15.4 devices.

Differing device designs

IEEE 802.15.4 devices are intentionally constrained in form factor to reduce costs (allowing for large-scale network of many devices), reduce power consumption (allowing battery powered devices) and allow flexibility of installation (e.g. small devices for body-worn networks). On the other hand, wired nodes in the IP domain are not constrained in this way; they can be larger and make use of mains power supplies.

Differing focus on parameter optimization

IPv6 nodes are geared towards attaining high speeds. Algorithms and protocols implemented within higher layers (such as TCP) are optimized to handle typical network problems such as congestion, however, in IEEE 802.15.4-compliant devices, energy conservation and code-size optimization remain at the top of the agenda.

Adaptation layer for interoperability and packet formats

An adaptation mechanism to allow interoperability between IPv6 domain and the IEEE 802.15.4 can best be viewed as a layer problem. Identifying the functionality of this layer and defining newer packet formats, if needed, is an enticing research area. RFC 4944 proposes an adaptation layer to allow the transmission of IPv6 datagrams over IEEE 802.15.4 networks.

Addressing management mechanisms

The management of addresses for devices that communicate across the two dissimilar domains of IPv6 and IEEE 802.15.4 is cumbersome, if not exhaustingly complex.

Routing considerations and protocols for mesh topologies in 6LoWPAN

Routing per se is a two-phased problem that is being considered for low-power IP networking:

Several routing protocols have been proposed by the 6LoWPAN community such as LOAD, DYMO-LOW, HI-LOW. However, only two routing protocols are currently legitimate for large-scale deployments: LOADng, standardized by the ITU under the recommendation ITU-T G.9903, and RPL, standardized by the IETF ROLL working group.

Routing

The 6LoWPAN routing scheme can be carried out in two different ways: mesh-under and route-over.

Mesh-under consists of implementing routing at the adaptation layer (which takes place between the link layer and the network layer of the OSI model), while route-over performs this implementation at the network layer (see 6LoWPAN routing scheme). In route-over, the IPv6 packet is reconstituted on each intermediate device in order to make the routing decision. Conversely, in mesh-under, the routing decision is made at the 6LoWPAN level and therefore only with fragments of the IPv6 packet. In this case, the IPv6 packet is only reconstituted on the recipient equipment. Therefore :

Improved versions of mesh-under and route-over have been proposed :

Initially, several routing protocols were developed by the 6LoWPAN community, such as LOAD, DYMO-LOW, HI-LOW.

Today, only two protocols are legitimate for large deployments:

Device and service discovery

Since IP-enabled devices may require the formation of ad hoc networks, the current state of neighboring devices and the services hosted by such devices will need to be known. IPv6 neighbour discovery extensions is an internet draft proposed as a contribution in this area.

Security

IEEE 802.15.4 nodes can operate in either secure mode or non-secure mode. Two security modes are defined in the specification in order to achieve different security objectives: Access Control List (ACL) and Secure mode

Header compression

There RFC 4944 defines the IPv6 header compression mechanism for LowPAN: LOWPAN_HC1. It also includes compression of the UDP header over 4 bytes, but does not allow compression of the Checksum. Additionally, it restricts the range of UDP ports from 61616 to 61631 in order to compress this value to 4 bits.

This IPv6 header compression can only be applied to local link addresses. To overcome this problem, an IETF LOWPAN_HC1g draft was published. LOWPAN_HC1g applies to global addresses for IP multi-hop communications. These two compression mechanisms (LOWPAN_HC1 and LOWPAN_HC1g) are complementary. It is therefore necessary to implement both.

Today the proposal of the 6LoWPAN group is to use LOWPAN_IPHC. It replaces LOWPAN_HC1 and LOWPAN_HC1g. IPHC bytes result from compression of the IPv6 header. They mainly integrate information from quality of service (DSCP and ECN), next headers, number of hops and compressed source/destination addresses.

With LOWPAN_IPHC the compression rate depends on the type of communication :

The example below shows the increase in payload compared to the original problem (see 1re figure). This payload is in the best case 70 to 75 bytes. Indeed, if we add the fragmentation information as indicated in the paragraph above, it will decrease to 65-70 bytes for this scenario.

History of 6LoWPAN

Technological developments in the 1990s (miniaturization of electronics, deployment of new wireless networks and embedded systems) enabled the emergence of new applications for sensor and actuator networks. With the advent of wireless technologies, the first solutions used were completely proprietary (for example Z-Wave or EnOcean). With the standard IEEE 802.15.4 (radio use of wireless sensors) new proprietary standards have appeared (for example, ZigBee, WirelessHART (in), etc.).

When first thinking about wireless sensor networking, 6LoWPAN was born from a simple idea: why reinvent a protocol when we already have IP? ".

2001
Geoff Mulligan proposes the use of IP on 802.15.4 for sensor type equipment. Although receiving unfavorable feedback from several groups like Zigbee, others like Internet 0 of MIT's Center for Bits and Atoms or the working group ROHC (from english RObust Header Compression, "robust header compression") of IETF were interested.
2005
2007
March
A first implementation of 6LoWPAN on TinyOS released on the implementation of "Arch Rock Company: Primer Pack/IP".
April
A first implementation of 6LoWPAN on TinyOS is available on the implementation of "Sensinode Company: NanoStack v0.9.4".
August
The 6LoWPAN group publishes the RFC 4919 to ensure the interoperability of the network layer.
September
There RFC 4944 sees the light of day, based on the RFC4919. This should allow direct connectivity to the Internet of LoWPAN equipment via IPv6 and replace them communication protocols owners like ZigBee,, which was developed after the end of the Smart Dust project.
2008
July
The IETF launches the ROLL Working Group.
September
The IPSO alliance (from English IP for Smart Objects, "IP for Smart Objects"), chaired by Geoff Mulligan, is created to promote the use of IP in smart objects. Smart objects are small type objects switch, detector more commonly called sensors.
2009
October
To develop smart grids, President Obama announces an investment of $3.4 billion.
2010
January
Study demonstrates significant economic prospects in IoT.
March
September
Cisco buys the company Arch Rock (one of the leaders in BAC applications for WSN), which strengthens the strategic alliance previously signed between Cisco and Itron (metering specialist smart grid),.
2011
January

See also

References

  1. 1 2 Zach Shelby and Carsten Bormann (2011-05-23). "6LoWPAN: The wireless embedded Internet – Part 1: Why 6LoWPAN?". eetimes. John Wiley & Sons, Ltd. Retrieved 2022-06-24. in '6LoWPAN: The Embedded Internet', Shelby and Bormann redefine the 6LoWPAN acronym as "IPv6 over lowpower wireless area networks," arguing that "Personal" is no longer relevant to the technology.
  2. ↑ "IPv6 over Low power WPAN (6lowpan)". IETF. Retrieved 10 May 2016.
  3. ↑ Mulligan, Geoff, "The 6LoWPAN architecture", EmNets '07: Proceedings of the 4th workshop on Embedded networked sensors, ACM, 2007
  4. ↑ Kushalnagar, N.; Intel Corp; Montenegro, G.; Microsoft Corporation; Schumacher, C.; Danfoss A/S (August 2007). "Problems". IPv6 over Low-Power Wireless Personal Area Networks (6LoWPANs): Overview, Assumptions, Problem Statement, and Goals. IETF. doi:10.17487/RFC4919. RFC 4919. Retrieved 2022-06-24.
  5. 1 2 "Thread 1.1 Specification Request Form". Thread Group. Retrieved 2022-06-24.
  6. ↑ "Thread Membership Benefits". Thread Group. Retrieved 2022-06-24.
  7. ↑ Sullivan, Mark (15 July 2014). "Nest, Samsung, ARM and others launch 'Thread' home automation network protocol". venturebeat.com. venture beat. Archived from the original on 4 February 2015. Retrieved 30 January 2015.
  8. ↑ Deering, A.; Cisco; Hinden, R.; Nokia (December 1998). "Packet Size Issues". IPv6 over Low-Power Wireless Personal Area Networks (6LoWPANs): Overview, Assumptions, Problem Statement, and Goals. IETF. doi:10.17487/RFC2460. RFC 2460. Retrieved 2022-06-24. IPv6 requires that every link in the internet have an MTU of 1280 octets or greater.
  9. ↑ Kim, K.; Daniel Park, S.; Montenegro, G.; Yoo, S.; Kushalnagar, N. (June 2007). 6LoWPAN Ad Hoc On-Demand Distance Vector Routing (LOAD). IETF. I-D draft-daniel-6lowpan-load-adhoc-routing-03. Retrieved 10 May 2016.
  10. ↑ Kim, K.; Montenegro, G.; Park, S.; Chakeres, I.; Perkins, C. (June 2007). Dynamic MANET On-demand for 6LoWPAN (DYMO-low) Routing. IETF. I-D draft-montenegro-6lowpan-dymo-low-routing-03. Retrieved 10 May 2016.
  11. ↑ Kim, K.; Yoo, S.; Daniel Park, S.; Lee, J.; Mulligan, G. (June 2007). Hierarchical Routing over 6LoWPAN (HiLow). IETF. I-D draft-daniel-6lowpan-hilow-hierarchical-routing-01. Retrieved 10 May 2016.
  12. ↑ Clausen, T.; Colin de Verdiere, A.; Yi, J.; Niktash, A.; Igarashi, Y.; Satoh, H.; Herberg, U.; Lavenu, C.; Lys, T.; Dean, J. (January 2016). The Lightweight On-demand Ad hoc Distance-vector Routing Protocol - Next Generation (LOADng). IETF. I-D draft-clausen-lln-loadng-14. Retrieved 10 May 2016.
  13. ↑ Winter, T.; Thubert, P.; Brandt, A.; Hui, J.; Kelsey, R.; Levis, P.; Pister, K.; Struik, R.; Vasseur, JP.; Alexander, R. (March 2012). RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks. IETF. doi:10.17487/RFC6550. RFC 6550. Retrieved 10 May 2016.
  14. ↑ "Routing Over Low power and Lossy networks (roll)". IETF. Retrieved 10 May 2016.
  15. ↑ Park, S.; Kim, K.; Haddad, W.; Chakrabarti, S.; Laganier, J. (March 2011). IPv6 over Low Power WPAN Security Analysis. IETF. I-D draft-daniel-6lowpan-security-analysis-05. Retrieved 10 May 2016.

Further reading