A CNAME record (for Canonical NAME) is a type of resource record in the Domain Name System (DNS) that maps one domain name (the alias) to another (the canonical name).: § 3.6.2
This can prove convenient when running multiple services (like an FTP server and a web server, each running on different ports) from a single IP address. One can, for example, use CNAME records to point ftp.example.com and www.example.com to the DNS entry for example.com, which in turn has an A record which points to the IP address. Then, if the IP address ever changes, one only has to record the change in one place within the network: in the DNS A record for example.com.
CNAME records must always point to another domain name, never directly to an IP address.
DNS CNAME records are specified in RFC 1034 and clarified in Section 10 of RFC 2181.
CNAME records are handled specially in the domain name system and have several restrictions on their use. When a DNS resolver encounters a CNAME record while looking for a regular resource record, it will restart the query using the canonical name instead of the original name. However, if the resolver is specifically told to look for CNAME records, the canonical name (righthand side) is returned, rather than restarting the query. The canonical name that a CNAME record points to can be anywhere in the DNS, whether local or on a remote server in a different DNS zone.
$ORIGIN example.com.
[…]
bar.example.com. 3600 IN CNAME foo.example.com.
foo.example.com. 3600 IN A 192.0.2.23
Consider the DNS zone shown at right: when an A record lookup for bar.example.com is carried out, the resolver will see a CNAME record and restart the lookup for foo.example.com, eventually returning 192.0.2.23.
With a CNAME record, one can point a name such as bar.example.com to foo.example.com. Because of this, during casual discussion, the lefthand (bar.example.com) side of a DNS entry can be incorrectly identified as the CNAME, however, this is inaccurate. The CNAME record stores the canonical (true) name of a host, making the righthand side the actual CNAME.
bar.example.com. 3600 IN CNAME foo.example.com.
This confusion is specifically mentioned in RFC 2181, "Clarifications to the DNS Specification". The left-hand label is an alias for the right-hand side (the RDATA portion), which is (or should be) a canonical name.: § 10.1.1 In other words, consider the CNAME record shown at right. This may be read as saying that bar.example.com is an alias for the canonical name foo.example.com. A client will request bar.example.com and the answer will be foo.example.com.
$ORIGIN example.com.
[…]
foo.example.com. 3600 IN CNAME bar.example.com.
bar.example.com. 3600 IN CNAME foo.example.com.
$ORIGIN example.com.
@ 3600 IN SOA ns1.example.com. hostmaster@example.com (
zone-admin.example.com.
[…] )
@ 2400 IN MX 0 foo.example.com.
foo.example.com. 3600 IN CNAME host.example.com.
host.example.com. 3600 IN A 192.0.2.1
A DNAME record (for Delegation NAME) is defined by RFC 6672 (the earlier RFC 2672 now being obsolete). The DNAME record provides redirection (alias) for a subtree of the domain name tree in the DNS. That is, all names that end with a particular suffix are redirected to another part of the DNS. In contrast, the CNAME record creates an alias for a single name and not its subdomains. Like the CNAME record, the DNS lookup will continue by retrying the lookup with the new name. The name server synthesizes a CNAME record to actually apply the DNAME record to the requested name—CNAMEs for every node on a subtree have the same effect as a DNAME for the entire subtree.
$ORIGIN example.com.
[…]
foo.example.com. 1200 IN DNAME bar.example.com.
bar.example.com. 3600 IN A 192.0.2.23
xyzzy.bar.example.com. 3600 IN A 192.0.2.24
*.bar.example.com. 3600 IN A 192.0.2.25
For example, if there is a DNS zone as seen at right, an A record lookup for foo.example.com will return no data because a DNAME is not a CNAME, and there is no A record defined for the foo host.
However, a lookup for xyzzy.foo.example.com will be DNAME mapped and return the A record for xyzzy.bar.example.com, which is 192.0.2.24; if the DNAME record had been a CNAME record, this request would have returned name not found.
Lastly, a request for foobar.foo.example.com would be DNAME mapped and return 192.0.2.25.
Several managed DNS platforms implement a non-standard ALIAS or ANAME record type. These pseudo records are managed by DNS administrators like CNAME records, but are published and resolved by (some) DNS clients like A records. ANAME records are typically configured to point to another domain, but when queried by a client, answer with an IP address. While ANAME record types were submitted for standardization, there are other non-conforming implementations, so they can do whatever the owner of the DNS platform chooses, including existing at the apex of a zone and existing for domains that receive mail.
The main advantage of ANAME records over CNAME records is that they can be used on a zone apex, while a standards-following resolver will not treat domain names with CNAME records as a zone apex. Also, while a DNS client requires at least two queries to resolve a CNAME to an A record to an IP address, an ANAME will shift the second and subsequent query to the server. If the DNS server can resolve the A record and cache the requested IP address more efficiently and with less latency than its DNS clients can, then the DNS client can resolve the query faster.
The ANAME record type was submitted as a draft standard to the IETF Domain Name System Operations (DNSOP) working group, however its most recent revision expired in January 2020, having not found the consensus needed for a proposal. It has since been superseded by a series of drafts for two other new record types that resulted in RFC 9460, titled "Service Binding and Parameter Specification via the DNS (SVCB and HTTPS Resource Records)," being approved as a Proposed Standard in November 2023.