Keith Moore (born 12 October 1960) is the author and co-author of several IETF RFCs related to the MIME and SMTP protocols for electronic mail, among others:
RFC1870, defining a mechanism to allow SMTP clients and servers to avoid transferring messages so large that they will be rejected;
RFC2017, defining a (rarely implemented) means to allow MIME messages to contain attachments whose actual contents are referenced by a URL;
RFC2047 amended by RFC2231, defining a mechanism to allow non-ASCII characters to be encoded in text portions of a message header (but not in email addresses);
RFC3464 obsoleting RFC1894, which together define a standard mechanism for reporting of delivery failures or successes in Internet email,
RFC3834, standards for processes that automatically respond to electronic mail; and
RFC8314, recommending the use of TLS for email submission and access, and the deprecation of cleartext versions of the protocols used for those purposes.
He has also written or co-written RFCs on other topics, including
RFC2964, Use of HTTP State Management (recommending constraints on the use of "cookies" to address privacy concerns);
RFC3205, On the use of HTTP as a Substrate (discussing the use of HTTP as a layer underneath other protocols); and
RFC3056, describing the 6to4 mechanism for tunneling IPv6 packets over an IPv4 network.