This article has multiple issues. Please help improve it or discuss these issues on the talk page. (Learn how and when to remove these messages)
|

The HTTP Framework for Time-Based Access to Resource States, also known as the Memento framework, is a method of denoting and obtaining historical revisions of HTTP resources, such as a web pages or files accessible by URL. Development of the framework was initiated as a project of the United States National Digital Information Infrastructure and Preservation Program (NDIIPP). It was funded with the aim of making Web-archived content more easily discoverable and accessible to the public.
The Memento project announced the shutdown of its hosted TimeTravel service on 5 September 2025.
Memento is defined in RFC 7089 as an implementation of the time dimension of content negotiation. HTTP accomplishes negotiation of content using headers that allow clients and servers to find content that the user desires.
| Request Header | Response Header | Dimension | Examples | Reference |
|---|---|---|---|---|
| Accept | Content-Type | media type of the representation, can include character set |
|
RFC 9110 (obsoletes RFC 7231) |
| Accept-Language | Content-Language | language of the representation |
|
RFC 9110 (obsoletes RFC 7231) |
| Accept-Encoding | Content-Encoding | medium, typically compression, that the content has been encoded with |
|
RFC 9110 (obsoletes RFC 7231) |
| Accept-Datetime | Memento-Datetime | time of the representation |
|
RFC 7089 |
The Last-Modified header provided by HTTP does not necessarily reflect when a particular version of a web page came into existence. Also, the Last-Modified header may not exist in some cases. To provide more information, the Memento-Datetime header has been introduced to indicate when a specific representation of a web page was observed on the web.

Copies of page can be found by simply navigating, in a web browser, to a link formatted, replacing urltoarchive with the full URL of the page desired.
JSON description of a Memento:
http://timetravel.mementoweb.org/api/json/YYYY/urltoarchivehttp://timetravel.mementoweb.org/api/json/YYYYMM/urltoarchivehttp://timetravel.mementoweb.org/api/json/YYYYMMDD/urltoarchivehttp://timetravel.mementoweb.org/api/json/YYYYMMDDHH/urltoarchivehttp://timetravel.mementoweb.org/api/json/YYYYMMDDHHMM/urltoarchiveOr redirect to a Memento with a datetime that is close to a desired datetime:
http://timetravel.mementoweb.org/memento/YYYY/urltoarchivehttp://timetravel.mementoweb.org/memento/YYYYMM/urltoarchivehttp://timetravel.mementoweb.org/memento/YYYYMMDD/urltoarchivehttp://timetravel.mementoweb.org/memento/YYYYMMDDHH/urltoarchivehttp://timetravel.mementoweb.org/memento/YYYYMMDDHHMM/urltoarchive