Noel Chiappa

Noel Chiappa
Born
Joseph Noel Chiappa

1956 (age 69–70)
EducationMIT
Scientific career
FieldsNetworking, routing protocols, TCP/IP
WorkplacesMIT, International Network Working Group, IETF, Proteon

Joseph Noel Chiappa (born 1956) is an American computer scientist, working in computer networks, information systems architecture, and software. He is pioneer of routing protocols, and contributed to the development of the modern internet through contributitions to the Internet protocol suite, for which he was named on the "Birth of the Internet" plaque at the entrance to the Gates Computer Science Building at Stanford University.

Early life and education

Chiappa was born in 1956 in Bermuda, attending Saltus Grammar School in Pembroke Parish. He attended secondary school and university in Massachusets, the former at Phillips Academy in Andover and in 1974 enrolled at the Massachusets Institute of Technology in Cambridge.

Chiappa's undergraduate tenure at MIT coincided with a reorganization and expansion of networking research of the university's DARPA-funded computer science research group (at the time known as "Project MAC") under newly appointed director Michael L. Dertouzos. In 1975, DARPA directed the group to change its research framework to token ring networking in collaboration with the protocol's developers, David J. Faber's group at the University of California, Irvine. This technology used PDP-11 interfaces, for which the group lacked an experienced programmer. Chiappa approached Project MAC with interest in their operating systems (OS) group, which was being deprioritized as a research focus in favor of networking. Experienced with PDP-11 programming, Chiappa was brought on to write diagnostics software for the PDP-11 LAN in exchange for support to perform OS research, but instead changed his focus to networking.

Career

Unveiling of the "Birth of the Internet" plaque at Stanford University in 2005. Chiappa's name is visible alongside the three other contributors from MIT.

In 1980, Chiappa started work on MIT's Chaosnet router, at the time the dedicated two-way network gateway into ARPANET, a major predecessor to the modern internet. This code routed Chaosnet and IP packets independently, and was later licensed to Proteon and formed the codebase of the first commercially available multiprotocol router, the Proteon p4200. The following year, Chiappa published the original version of Trivial File Transfer Protocol (TFTP).

In addition to being present on the "Birth of the Internet" plaque, Chiappa is acknowledged and authored numerous RFC's important in the history of modern networking such as RFC-826, RFC-919, and RFC-950. He has worked extensively on the Locator/Identifier Separation Protocol (LISP). In 1992, Chiappa was also credited for fixing the "Sorcerer's Apprentice" protocol bug as well as other document problems. He served as the first Internet Area Director on the Internet Engineering Steering Group, from 1989 to 1992.

From 2012, Chiappa worked on long-term issues in both the Internet Research Task Force and Internet Engineering Task Force and its predecessors, serving as the first Area Director for Internet Services of the Internet Engineering Steering Group from 1987 to 1992.

Personal life

Chiappa lives in Yorktown, Virginia with his family. He is an expert curator and collector of Asian fine art, particularly Japanese woodblock prints, about which he has produced documentation and glossaries. In 2003 and 2007, he exhibited his personal collections at the Bermuda National Gallery in Hamilton, Bermuda.

Notes

  1. ↑ Plaque image
  2. ↑ Chiappa, Noel. "Biography of J. Noel Chiappa". Retrieved September 11, 2022.
  3. ↑ "Massachusetts Institute of Technology. Laboratory for Computer Science: Historical Note". archivesspace.mit.edu. MIT Libraries. Retrieved 2026-10-18.
  4. ↑ "In Memoriam: David J. Farber – Communications of the ACM". 2026-02-19. Retrieved 2026-10-18.
  5. ↑ "Token Ring and David Farber, UC Irvine and the NSF 1969-1974 | History of Computer Communications". historyofcomputercommunications.info. Retrieved 2026-10-18.
  6. 1 2 "IMS: Noel Chiappa, Geek of the Week". town.hall.org. Retrieved 2026-10-18.
  7. ↑ admin. "European ARPANET 50th Anniversary". Faculty of Engineering. Retrieved 2026-10-18.
  8. ↑ Zhang, Lixia (1987). How to build a Gateway -- C-Gateway: An Example (The Second International Conference on Computers and Applications, Beijing (Peking), Peopleʼs Republic of China, June 23-27, 1987). Washington, D.C.: Computer Society Press of the IEEE; Los Angeles, CA : Order from Computer Society of the IEEE. pp. 461–468. ISBN 978-0-8186-0780-6.
  9. ↑ "History lesson: The origins of wiki, blog and other high-tech lingo". Computerworld. Retrieved 2026-10-18.
  10. ↑ Cringely, Robert X. (1998-12-10). "Valley of the Nerds: Who Really Invented the Multiprotocol Router, and Why Should We Care?". Public Broadcasting Service. Archived from the original on 2007-10-11. Retrieved 2024-01-11.
  11. ↑ "Proteon | History of Computer Communications". historyofcomputercommunications.info. Retrieved 2026-10-18.
  12. ↑ RFC 783: The TFTP Protocol (Revision 2) June 1981, Obsoleted by RFC-1350 July 1992
  13. ↑ "RFC 826: An Ethernet Address Resolution Protocol: Or Converting Network Protocol Addresses to 48.bit Ethernet Address for Transmission on Ethernet Hardware". Internet Engineering Task Force. November 1982.
  14. ↑ Mogul, J. C. (1984-10). Broadcasting Internet Datagrams (Report). Internet Engineering Task Force. doi:10.17487/RFC919. {{cite report}}: Check date values in: |date= (help)
  15. ↑ "RFC 919: Broadcasting Internet Datagrams". Internet Engineering Task Force. October 1984.
  16. ↑ "RFC 950: Internet Standard Subnetting Procedure". Internet Engineering Task Force. August 1985.
  17. ↑ "RFC 9299: An Architectural Introduction to the Locator/ID Separation Protocol (LISP)". IETF. October 2022. Retrieved 2026-04-22.
  18. ↑ McNeil, John (2019). So you want to write a Java desktop application. Software Pulse. p. 118. ISBN 9780244754129.
  19. ↑ IESG Past Members
  20. ↑ Borsook, Pauline (21 May 1990). "SNMP vs. CMOT, again". IDG Network World Inc.
  21. ↑ "IEEE Xplore: J. Noel Chiappa". IEEE.
  22. ↑ Malkin, Gary S. (August 1991). "RFC 1251: Who's Who in the Internet: Biographies of IAB, IESG and IRSG Members". IETF. Retrieved 2026-04-22.
  23. ↑ Chiappa, Noel. "Brief biography of J. Noel Chiappa". Retrieved November 1, 2016.
  24. ↑ "Asian Art | History of Art & Architecture". www.bu.edu. Retrieved 2026-10-18.
  25. ↑ "Miscellaneous". www.hiroshige.org.uk. Retrieved 2026-10-18.
  26. ↑ Acton, Nancy (2003-12-31). "Bermuda Year End: Bermuda shows its face to the world". Retrieved 2026-10-18.
  27. ↑ "Prints Charming". Archived from the original on 2026-10-18. Retrieved 2026-10-18.