IP over Avian Carriers

IP over Avian Carriers (IPoAC; eesti keeles "IP lindude kaudu") on humoorikas, kuid näiliselt toimiv ettepanek edastada internetiprotokolli (IP) liiklust lindude, näiteks kirjatuvide vahendusel. Seda kirjeldati esmakordselt dokumendis RFC 1149, mille avaldas Internet Engineering Task Force (IETF). Selle autor on David Waitzman ja see ilmus 1. aprillil 1990. Tegemist on ühega mitmest aprillinaljana mõeldud kommentaarinõude-dokumendist (Request for Comments ehk RFC).

Waitzman kirjeldas oma protokolli täiustatud versiooni dokumendis RFC 2549 pealkirjaga "IP lindude kaudu koos teenusekvaliteediga" (IP over Avian Carriers with Quality of Service), mis avaldati 1. aprillil 1999. Hiljem, 1. aprillil 2011 – 13 aastat pärast IPv6 kasutuselevõttu – avaldasid Brian Carpenter ja Robert Hinden dokumendi RFC 6214, mis käsitleb RFC 1149 kohandamist IPv6 jaoks.

IPoAC-i on edukalt rakendatud 2001. aastal, kui sellega katsetas Bergenis Linuxi kasutajagrupp, kuid vaid üheksa andmepaketi edastamiseks. Seda nimetati kui CPIP (Carrier Pigeon Internet Protocol ehk kirjatuvide internetiprotokoll). Paketikadu oli 55% (operaatori vea tõttu) ning vastusaeg jäi vahemikku 3000 sekundit (50 minutit) kuni üle 6000 sekundi (100 minutit). Seega iseloomustab seda tehnoloogiat äärmiselt suur latentsusaeg.

Fotograafid on kasutanud tuvisid ka omamoodi "füüsilise võrguna" (inglise sneakernet), et toimetada edasi mälukaarte digifotodega. Nii võib üks tuvi kanda kümneid gigabaite andmeid ning saavutada keskmise andmeedastuskiiruse, mis isegi arvestades kaduma läinud andmekandjaid, ületab varajasi ADSL-standardeid.

Viited