Le Sieve (du mot anglais crible comme dans le crible d'Ératosthène) est un langage de filtrage du courrier électronique. Il suit la recommandation RFC 5228.
Le Sieve permet de filtrer les en-têtes d'un message qui suit le format RFC 5322, c'est-à-dire d'un message Internet typique.[pas clair]
Outre le langage de base, de nombreuses extensions (pas forcément mises en œuvre dans tous les logiciels) ont été définies[pas clair], par exemple pour utiliser des tests anti-spam ou antivirus (RFC 5235), ou bien pour tester sur des sous-adresses[pas clair] (RFC 5233).
Un script très simple en Sieve :
require "fileinto";
# Déplacer les messages contenant « Wikipedia » dans le sujet vers le répertoire « INBOX.Wikipedia »
if header :contains "Subject" "Wikipedia"
{
fileinto "INBOX.Wikipedia";
}