Un type de médias (media type en anglais), à l'origine (et toujours communément) appelé type MIME, est un identifiant de format de données sur internet en deux parties.
Les types de médias étaient à l'origine définis dans la RFC 2046 (publiée en ) pour leur utilisation dans les courriels à travers le protocole SMTP, mais ils ont été étendus à d'autres protocoles comme le HTTP ou le SIP dans la RFC 6838 (publiée en ).
Un type de médias est composé d'au moins deux parties : un type et un sous-type structuré en arbre avec un suffixe optionnel, et de paramètres optionnels :
type "/" [arbre "."] sous-type ["+" suffixe] *[";" paramètre]L'IANA définit actuellement les dix types suivants : application, audio, example, font, image, message, model, multipart, text et video, ainsi que les quatre arbres de sous-type suivants : arbre standard (sans préfixe), arbre éditeur (préfixe vnd.), arbre personnel (préfixe prs.) et arbre non enregistré (préfixe x.).
Par exemple, le type de médias text/html; charset=UTF-8 est composé du type text, du sous-type html de l'arbre standard et du paramètre optionnel charset=UTF-8.
D'après la RFC 6838, l'utilisation de la catégorie de sous-type non enregistré (préfixe x.) est fortement déconseillée. De plus les sous-types préfixés par x- ou X- ne sont plus considérés comme appartenant à cette catégorie.
L'IANA entretient un registre des types de médias et des codages de caractères.
Quelques-uns des types de médias les plus courants sont listés ci-après :
application : fichiers pluri-usages.
application/EDI-X12 : données EDI ANSI ASC X12 ; défini dans la RFC 1767.application/EDIFACT : données EDI EDIFACT ; défini dans la RFC 1767.application/octet-stream : flux de données arbitraire. Considéré comme le format « par défaut » dans plusieurs OS, souvent utilisé pour identifier des fichiers exécutables, ou de type inconnu, ou des fichiers qui doivent être téléchargés grâce à des protocoles qui ne fournissent pas de champ « content disposition » dans leur en-tête. La RFC 2046 le décrit comme un recours pour les sous-types et les types non reconnus.application/ogg : Ogg, un flux de données multimedia, conteneur ; défini dans la RFC 3534.application/pdf: Portable Document Format, PDF, utilisé pour les échanges de documents depuis 1993 ; défini dans la RFC 3778.application/xhtml+xml : XHTML ; défini dans la RFC 3236.application/x-shockwave-flash : fichier Adobe Flash ; documenté par Adobe TechNote tn_4151 et Adobe TechNote tn_16509.application/json : JavaScript Object Notation ; défini dans la RFC 4627.application/ld+json : JSON-based Serialization for Linked Data.application/xml : eXtensible Markup Language ; défini dans la RFC 3023.application/zip : fichier ZIP.application/vnd.oasis.opendocument.text : texte OpenDocument (enregistré).application/vnd.oasis.opendocument.spreadsheet : feuille de calcul OpenDocument (enregistré).application/vnd.oasis.opendocument.presentation : présentation OpenDocument (enregistré).application/vnd.oasis.opendocument.graphics : graphique OpenDocument (enregistré).application/vnd.ms-excel : fichiers Microsoft Excel (.xls).application/vnd.openxmlformats-officedocument.spreadsheetml.sheet : Office Open XML Workbook (.xlsx) (Format d'enregistrement par défaut sous Microsoft Excel à partir de 2007).application/vnd.ms-powerpoint : fichiers Microsoft Powerpoint (.ppt).application/vnd.openxmlformats-officedocument.presentationml.presentation : Office Open XML Presentation (.pptx) (Format d'enregistrement par défaut sous Microsoft PowerPoint à partir de 2007).application/msword : fichiers Microsoft Word (.doc).application/vnd.openxmlformats-officedocument.wordprocessingml.document : Office Open XML Document (.docx) (Format d'enregistrement par défaut sous Microsoft Word à partir de 2007).application/vnd.mozilla.xul+xml : fichiers Mozilla XUL.audio : audio.
audio/mpeg : MP3 ou autres MPEG ; défini dans la RFC 3003 (attention, sur certains navigateurs tels que Chromium et Google Chrome le content-type est : audio/mp3).audio/x-ms-wma : Windows Media Audio ; documenté par (en) « Microsoft KB 288102 » (version du sur archive.org).audio/vnd.rn-realaudio : RealAudio ; documenté par RealPlayer Customer Support Answer 2559.audio/x-wav : WAV (attention, sur certains navigateurs tels que Chromium et Google Chrome le content-type est : audio/wav).example.font.image.
image/gif : GIF ; défini dans la RFC 2045 et la RFC 2046.image/jpeg : JPEG image JFIF ; défini dans la RFC 2045 et la RFC 2046 (attention, sur le navigateur Internet Explorer le type MIME peut être « image/pjpeg »).image/png : Portable Network Graphics ; enregistré (attention, à l'instar du jpeg sur le navigateur Internet Explorer le type MIME peut être « image/x-png »).image/tiff : Tagged Image File Format ; défini dans la RFC 3302.image/vnd.microsoft.icon : icône ICO; enregistréimage/x-icon est aussi très utilisé).image/vnd.djvu : DjVu ; format d'image et de document multipage.image/svg+xml : image vectorielle SVG ; défini dans SVG Tiny 1.2 Specification Appendix M.message.model : modèle 3D.multipart : archive et autres objets composés de plus d'une seule partie.
text : texte lisible par un être humain ou code source.
text/css : feuilles de style en cascade ; défini dans la RFC 2318.text/csv : comma-separated values ; défini dans la RFC 4180.text/html : HTML ; défini dans la RFC 2854.text/javascript : JavaScript ; défini dans la RFC 9239.text/plain : données textuelles ; défini dans la RFC 2046 et la RFC 3676.text/xml : Extensible Markup Language ; défini dans la RFC 3023.video : vidéo.
video/mpeg : MPEG-1, vidéo avec son multiplexé ; défini dans la RFC 2045 et la RFC 2046.video/mp4 : vidéo MP4 ; défini dans la RFC 4337.video/quicktime : vidéo QuickTime ; enregistré.video/x-ms-wmv : Windows Media Video ; documenté par (en) « Microsoft KB 288102 » (version du sur archive.org).video/x-msvideo : vidéo dans un conteneur AVI.video/x-flv : Flash Video (FLV) par Adobe Systems.video/web: basé sur un conteneur dérivé Matroska.