Jetty

Jetty

FejlesztőEclipse Foundation eredetileg Mort Bay Consulting
Legfrissebb stabil kiadás12.1.14 (stabil verzió, 2026. október 5.)
Legfrissebb fejlesztői kiadás8.0.0.RC0 (2011. augusztus 16.) +/-
Programozási nyelvJava
Operációs rendszerplatformfüggetlen (JVM)
PlatformJava platform
Állapotaktív
Kategóriaalkalmazásszerver
LicencApache License 2.0
Kódtárhttps://github.com/jetty/jetty.project
A Jetty weboldala

A Jetty egy tisztán Javában írt webszerver és servlet container. Míg a webszervereket általában az emberek dokumentumokkal való kiszolgálásával hozzák kapcsolatban, a Jettyt gyakran használják gép-gép közötti kommunikációra, különösen nagyobb szoftver keretrendszereken belül. A Jettyt szabad és nyílt forráskódú projektként fejlesztik, az Eclipse Foundation részeként. A webszervert olyan projektekben használják, mint például az Apache ActiveMQ, Alfresco, Apache Geronimo, Apache Maven, Apache Spark, Google App Engine, Eclipse, FUSE, iDempiere, Twitter's Streaming API és a Zimbra. Jetty olyan nyílt forráskódú projektek szervere, mint például a Lift, Eucalyptus, Red5, Hadoop és I2P. A Jetty támogatja a Java Servlet API-t (JSP támogatással) éppúgy, mint a HTTP/2 és WebSocket protokollokat.

Áttekintés

A projekt célja egy egyszerű, hatékony és beágyazható webszerver létrehozása. A Jetty kis méretéből eredően alkalmas web service-ek működtetésére beágyazott Java alkalmazásokban.

Független, nyílt forráskódú projektként fejlesztve 2009-ben a Jettyt átköltöztették az Eclipsehez. A Jetty képes webszolgáltatásokat nyújtani beágyazott Java alkalmazásokban. Mára része komponense az Eclipse IDEnek. Támogatja a következőket: AJP, JASPI, JMX, JNDI, OSGi, WebSocket és más Java-s technológiák.

Története

Eredetileg Sydneyben, Balmain-ben fejlesztette Greg Wilkins szoftverfejlesztő. Jetty eredetileg egy Mort Bay Szerver HTTP szerver komponense volt (Mort Bay Balmain egy körzete).

Jetty-t 1995-ben kezdték és MortBay szerverén volt elérhető az 1.x majd 2.x változat, egészen 2000-ig. 2000 és 2005 között, Jetty átkerült a sourceforge.net-re, ahol a 3.x, 4.x, majd 5.x verzió letölthető volt. 2005-ben az Jetty projektet átköltöztették a codehaus.org-ra. 2009-ben a főbb Jetty komponenseit átköltöztették az Eclipse.org-ra, és a Codehaus.org továbbra is nyújtott integrációt, kiegészítéseket, és Jetty csomagokat a 7.x és a 8.x verziókhoz (a 9.x-hez már nem).

VerzióHomeSzükséges java verzióHTTP verzióServlet verzióJSP VerzióStátusz
9.3.x Eclipse 1.8 HTTP/1.1, HTTP/2, WebSocket JSR356, SPDY 3.1 2.3 Stabil 2015-02-25 óta
9.2.x Eclipse 1.7 HTTP/1.1, WebSocket JSR356, SPDY 3.1 2.3 Stabil 2014-04-16 óta
9.1.x Eclipse 1.7 HTTP/1.1, WebSocket JSR356, SPDY 3.1 2.3 Stabil 2013-11-18 óta
9.0.x Eclipse 1.7 HTTP/1.1, WebSocket, SPDY 3.0 (tracking 3.1 drafts) 2.2 Stabil 2013-03-08 óta
8.xEclipse, Codehaus1.6HTTP/1.1 RFC26163.02.1Stabil
7.xEclipse, Codehaus1.5, J2MEHTTP/1.1 RFC26162.52.1Stabil
6.xCodehaus1.4-1.5HTTP/1.1 RFC26162.52.0Érett
5.xSourceforge1.2-1.5HTTP/1.1 RFC26162.42.0Elavult
4.xSourceforge1.2, J2MEHTTP/1.1 RFC26162.31.2Nagyon régi
3.xSourceforge1.2HTTP/1.1 RFC20682.21.1Fosszilizált
2.xMortbay1.1HTTP/1.0 RFC19452.11.0Legendás
1.xMortbay1.0HTTP/1.0 RFC1945Mítikus

Kapcsolódó szócikkek

További információk

Jegyzetek

  1. ↑ "Release 12.1.14". 2026. október 5. Hozzáférés: 2026. október 6.
  2. ↑ "ActiveMQ with Ajax and Jetty". Jetty Wike (Codehaus). 2011. augusztus 30. dátummal az eredeti címről archiválva. Hozzáférés: 2011. április 12.
  3. ↑ JM.Pascal (2010. április). "Maven + Alfresco : Jetty, Boostrap and Profil". Going to an OpenSource ECM World.... 2012. január 7. dátummal az eredeti címről archiválva. Hozzáférés: 2011. április 12.
  4. ↑ "Configuring Virtual Hosts in Geronimo-Jetty". Apache Geronimo Documentation. 2018. december 1. dátummal az eredeti címről archiválva. Hozzáférés: 2011. április 12.
  5. 1 2 Wickesser, Craig (2009. augusztus 5.). "Google Chose Jetty for App Engine". InfoQ. C4Media Inc. Hozzáférés: 2011. április 12.
  6. ↑ "jetty://". Eclipse. Hozzáférés: 2011. április 12.
  7. ↑ "class JettyHttpComponent". FuseSource. Red Hat. 2011. március 15. dátummal az eredeti címről archiválva. Hozzáférés: 2011. április 12.
  8. ↑ "Platform Upgrade for r3". Hozzáférés: 2014. április 8.
  9. ↑ "Twitter Streaming API and Apache Wink". 2016. március 15. dátummal az eredeti címről archiválva. Hozzáférés: 2011. május 19.
  10. ↑ Zhuang, JJ (2007. december 18.). "Zimbra Blog: Why we switched to Jetty". Zimbra. VMware. 2011. július 21. dátummal az eredeti címről archiválva. Hozzáférés: 2011. április 12.
  11. ↑ "Powered by Jetty". 2020. június 28. dátummal az eredeti címről archiválva. Hozzáférés: 2012. szeptember 24.
  12. ↑ Lieber, Adam (2008. december). "Jetty: The Twelve Year Journey to Market Maturity". Linux Gazette. Hozzáférés: 2013. június 28.
  13. ↑ "About Jetty". Codehaus. 2012. január 6. dátummal az eredeti címről archiválva. Hozzáférés: 2011. november 30.
  14. 1 2 Archiválva 2015. május 31-i dátummal a Wayback Machine-ben, About Jetty Located on Codehaus.
  15. 1 2 3 4 5 6 Archiválva 2010. november 21-i dátummal a Wayback Machine-ben, About Jetty Located on Eclispe.
  16. ↑ "What Version". eclipse.org. 2015. május 13. 2020. október 14. dátummal az eredeti címről archiválva. Hozzáférés: 2015. május 13.
  17. ↑ "jetty 9.3.0 release review". Dev.eclipse.org. 2015. február 25. Hozzáférés: 2015. április 22.
  18. ↑ "jetty 9.2.0 release review". Dev.eclipse.org. 2014. április 16. Hozzáférés: 2015. április 22.
  19. ↑ "[jetty-announce] Jetty 9.1.0.v20131115 Stable Release!". Dev.eclipse.org. 2013. november 18. Hozzáférés: 2014. július 17.
  20. ↑ "[jetty-announce] Announcing Jetty 9.0.0". Dev.eclipse.org. 2013. március 8. Hozzáférés: 2014. július 17.

Fordítás

Ez a szócikk részben vagy egészben a Jetty című angol Wikipédia-szócikk ezen változatának fordításán alapul. Az eredeti cikk szerkesztőit annak laptörténete sorolja fel. Ez a jelzés csupán a megfogalmazás eredetét és a szerzői jogokat jelzi, nem szolgál a cikkben szereplő információk forrásmegjelöléseként.