Uniform Resource Name

Et uniformt ressursnavn (URN, engelsk: «Uniform Resource Name») er en URI som er globalt unik og varig, selv om informasjon om ressursen ikke eksisterer eller ikke lenger er tilgjengelig på internettet.

Formålet med URN er å tilby en globalt unik og varig identifikator, som kan brukes for gjenkjennelse av en ressurs, tilgang til en ressurs' egenskaper eller for tilgang til selve ressursen.

URN-er er del av en større Internett-arkitektur, hvor Uniform Resource Characteristics (URC-er), Uniform Resource Locators (URL-er) og URNer hver utgjør medlemmene. Hver har sin spesifikke rolle i denne arkitekturen:

Funksjonelle krav

RFC 1737 definerer et sett med funksjonelle krav til URN

URN Syntaks

RFC 2141 (datert Mai 1997 og fremdeles klassifisert som med behov for diskusjon og forslag til forbedringer) beskriver i BNF-form syntax for URN slik:

  <URN> ::= "urn:" <NID> ":" <NSS>

hvor <NID> er Namespace Identifier (navneromidentifikator) og <NSS> er Namespace Specific String (navneromspesifikk streng). Deler angitt i hermetegn er betegnet som påkrevd. "urn:" er tillatt skrevet med både små og store bokstaver. Mao. er Urn:, uRn:, URN:, urn: alle tillatt. Navneromsidentifikatoren bestemmer den syntaktiske tolkningen av den navneromspesifikke strengen.

URN og IETF

Internet Engineering Task Force (IETF) har en arbeidsgruppe som har som mål å utarbeide ett rammeverk for URNer, samt et sett med komponenter som er tilpasset dette rammeverket. Resultatet fra denne arbeidsgruppen er et sett med RFCer, hvor antageligvis de meste relevante er RFC 2611 – URN Namespace Definition Mechanisms, RFC 2141 – URN Syntax og RFC 2276 – Architectural Principles of Uniform Resource Name Resolution.

Referanser

  1. ↑ Trond Aalberg og Knut Hegna (2000). Arkitektur for digitale bibliotek (PDF). s. 91. ISBN 82-7729-027-6. Arkivert fra originalen (PDF) 9. november 2007.
  2. ↑ RFC 1737 Functional Requirements for Uniform Resource Names
  3. ↑ «Uniform Resource Names (urn) – IETF working group charter». Arkivert fra originalen 13. november 2004. Besøkt 25. juli 2008.
  4. ↑ Trond Aalberg og Knut Hegna (2000). Arkitektur for digitale bibliotek (PDF). s. 114. ISBN 82-7729-027-6. Arkivert fra originalen (PDF) 9. november 2007.