Typ MIME

Media type, typ MIME, Content-Type – dwuczęściowy identyfikator formatu danych przesyłanych w Internecie. Oryginalnie zdefiniowany w RFC 2046 ↓ do użycia w ramach nagłówków poczty elektronicznej. Z czasem rozprzestrzenił się na inne zastosowania i protokoły jak HTTP czy SIP. Rolą tego nagłówka jest umożliwienie programowi użytkownika dobrania odpowiedniego programu potrafiącego obsłużyć przesłany przez serwer zasób.

Podstawowa forma identyfikatora składa się z dwóch części: typu i podtypu rozdzielonych znakiem ukośnika, którym mogą towarzyszyć opcjonalne parametry. Podtypy typu text posiadają np. opcjonalny parametr charset używany do wskazania kodowania znaków, a podtypy dla multipart często definiują parametr boundary jako separator poszczególnych części. Typy lub podtypy zaczynające się od „x-” są traktowane jako niestandardowe i jako takie nie są rejestrowane w Internet Assigned Numbers Authority (IANA). Podtypy zaczynające się od vnd. należą do prywatnych rozszerzeń dostawców.

Przykłady popularnych typów

IANA utrzymuje rejestr identyfikatorów typów wraz z rejestrem identyfikatorów kodowań znaków. Lista ta jest dostępna w Internecie.

Przykłady:

Zobacz też

Uwagi

Przypisy

  1. ↑ Internet Media Type registration, consistency of use [online], W3C, 3 czerwca 2002 [dostęp 2006-11-29] (ang.).
  2. 1 2 RFC 2045 ↓, s. 10–11.
  3. ↑ RFC 2045 ↓, sekcja 6.3, s. 15.
  4. ↑ RFC 2048 ↓, sekcja 2.1.2, s. 3–4.
  5. 1 2 3 4 5 RFC 2046 ↓, s. 5, 11–13.
  6. ↑ RFC 3676 ↓, s. 1–20.
  7. ↑ RFC 2318 ↓, s. 1–2.
  8. ↑ RFC 2854 ↓, s. 2.
  9. ↑ RFC 3023 ↓, s. 5–7.
  10. ↑ RFC 4329 ↓, s. 8–12.
  11. ↑ RFC 4627 ↓, s. 6.
  12. ↑ RFC 3534 ↓, s. 2.
  13. ↑ RFC 3236 ↓, s. 2.
  14. ↑ RFC 3003 ↓, s. 2.
  15. ↑ MIME Type Settings for Windows Media Services. Microsoft, 2003-11-03. [dostęp 2023-07-28]. [zarchiwizowane z tego adresu (2012-12-08)].
  16. ↑ W3C PNG Working Group: Media type name: image / Media subtype name: png. 2021-12-07. [dostęp 2023-07-28]. (ang.).
  17. ↑ RFC 3302 ↓, s. 3.
  18. ↑ Simon Butcher: MIME media type name : Image / MIME subtype name : Vendor Tree - vnd.microsoft.icon. 2003-09-03. [dostęp 2023-07-28]. (ang.).
  19. 1 2 RFC 2046 ↓, s. 24–26.
  20. ↑ RFC 2387 ↓, s. 1–8.
  21. ↑ RFC 4337 ↓, s. 3–5.
  22. ↑ Paul Lindner: Registration of new MIME content-type/subtype. 1993-06-04. [dostęp 2023-07-28]. (ang.).
  23. ↑ Microsoft KB 288102

Linki zewnętrzne