Type of Service – pole w nagłówku IPv4 opisujące ważność i wymagania pakietu. Według najnowszej definicji RFC, TOS składa się z sześciobitowego pola Differentiated Services Code Point oraz dwubitowego pola Explicit Congestion Notification.
| 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 |
|---|---|---|---|---|---|---|---|
| Bity początkowe | D | T | R | pole ECN | |||
Bajt TOS przez lata miał wiele różnych zastosowań, został zdefiniowany w różny sposób przez 5 różnych dokumentów RFC (RFC 791 ↓, RFC 1122 ↓, RFC 1349 ↓, RFC 2474 ↓, oraz RFC 3168 ↓.) Cała historia bajtu TOS jest opisana w 22. sekcji dokumentu RFC 3168 ↓.
8 bitów w nagłówku IP jest zarezerwowanych dla TOS. Mogą one zostać podzielone na 5 podpól:
3 najstarsze bity zawierają wartości od 0 do 7 i używane są do oznaczania ważności datagramu. Domyślną wartością jest 0 (im wartość wyższa tym datagram ważniejszy).
Bity 3 4 5 opisują co następuje:
Najmłodsze dwa bity zarezerwowane są na pole ECN.
Router utrzymuje wartość TOS dla każdej trasy w swojej tablicy routingu. Trasy wyuczone poprzez protokoły nieobsługujące TOS otrzymują domyślną wartość 0. Routery używają TOS do wybierania trasy dla pakietu.
Proces wyboru trasy dla pakietu z określonym TOS: