JSON Meta Application Protocol

Lo JSON Meta Application Protocol (JMAP) è uno standard di Internet che definisce un protocollo di comunicazione per la gestione della posta elettronica. Utilizza API in formato JSON su HTTP ed è stato sviluppato come alternativa ai protocolli IMAP e SMTP ed altri protocolli proprietari utilizzati da Gmail e Outlook.

Storia

Il suo sviluppo è cominciato nel 2014 da parte del fornitore di servizi di posta elettronica australiano Fastmail per trovare un sostituto all'IMAP che ne risolvesse i problemi di complessità, consumo di risorse e scarsa adattabilità alle necessità dei moderni dispositivi mobili. Dal 2017 lo sviluppo e la standardizzazione sono curati da un gruppo di lavoro presso l'Internet Engineering Task Force.

Nel 2019 vengono pubblicati la base del protocollo e le specifiche per la posta elettronica come standard RFC 8620 e RFC 8621 rispettivamente. Le specifiche per il WebSocket e per le ricevute di ritorno sono state invece pubblicate nel 2020 (RFC 8887) e 2021 (RFC 9007) rispettivamente. Ulteriori specifiche sono in corso di definizione per supportare i calendari, la rubrica e i filtri.

Note

  1. ↑ (EN) JSON Mail Access Protocol (jmap), su datatracker.ietf.org.
  2. ↑ (EN) RFC 8620: The JSON Meta Application Protocol (JMAP), su rfc-editor.org.
  3. ↑ (EN) RFC 8621: The JSON Meta Application Protocol (JMAP) for Mail, su rfc-editor.org.
  4. ↑ (EN) RFC 8887: A JSON Meta Application Protocol (JMAP) Subprotocol for WebSocket, su rfc-editor.org.
  5. ↑ (EN) RFC 9007: Handling Message Disposition Notification with the JSON Meta Application Protocol (JMAP), su rfc-editor.org.

Voci correlate

Collegamenti esterni

  Portale Telematica: accedi alle voci di Wikipedia che parlano di reti, telecomunicazioni e protocolli di rete