| 通信プロトコル | |
| 目的 | Webサーバ上のファイル管理 |
|---|---|
| 開発者 | ジム・ホワイトヘッド、Internet Engineering Task Force(IETF) |
| 導入 | 1996年 |
| 派生元 | HTTP |
| 派生先 | Delta-V、CalDAV、GroupDAV |
| OSI階層 | アプリケーション層 |
| ポート | 80, 443 |
| RFC | RFC 2518, RFC 4918 |
WebDAV(Web-based Distributed Authoring and Versioning、ウェブダブ)はHTTPを拡張したもので、Webサーバ上のファイル管理を目的とした分散ファイルシステムを実現するプロトコルである。
2023年11月、マイクロソフトはWebDAVをWindowsの非推奨機能の一つと発表した。
WebDAVは、Webサーバに対して直接ファイルのコピーや削除を行ったり、ファイル所有者や更新日時などのファイル情報を取得・設定するといった機能を持つ分散ファイルシステムで、HTTP 1.1を拡張したプロトコルで実現される。元々はファイルのバージョン管理機能も内包していたが、後に RFC 3253 で定義されたDelta-Vに分離された。
マイクロソフトによって最初に開発され、1999年2月に RFC 2518 が発表された。2007年6月に発表された RFC 4918 が2008年1月現在最新の定義である。
Webサーバ等でコンテンツのアップロードや更新を行う際に、FTPやscpのような別のサービス・プロトコルを使うことなく、HTTPだけで全てのコンテンツ管理を完結できる。また、HTTPの拡張のみによって実装されているため、ファイアウォールによって既存のファイル転送サービスが利用できない環境や、HTTPプロキシを経由した環境でも利用できる。
WebDAVは1996年にジム・ホワイトヘッドがワールドワイドウェブコンソーシアム(W3C)と協力して、ワールドワイドウェブ上での分散型オーサリングの問題について関心のある人々と話し合うための会議を開催したことから始まった。ティム・バーナーズ=リーのウェブの当初の構想は、読み書き両方の媒体を含むものであった。実際、バーナーズ=リーの最初のウェブブラウザであるWorldWideWebは、ウェブページを表示および編集することができたが、ウェブが成長するにつれて、ほとんどのユーザーにとって読み取り専用の媒体となった。ホワイトヘッドとそれを賛同する人々は、そうした状況を変えたいと考えた。
これらの会合の結果、IETFワーキンググループが結成された。IETFとしてもこの新たな取り組みは、IETFが標準化に着手していたHTTPの拡張につながるものだったためである。プロトコルの開発が始まると、分散オーサリングとバージョン管理の両方を同時に扱うには膨大な作業量が必要となり、タスクを分離する必要があることが明らかになった。WebDAVグループは分散オーサリングに注力し、バージョン管理は将来的に取り組むことにした。
WebDAVワーキンググループは、インターネット技術運営グループ(IESG)がRFC 2518の増分更新を承認した後、2007年3月に作業を終了した。当時未完成だったその他の拡張機能(BINDメソッドなど)は、正式なワーキンググループとは関係なく、それぞれの担当者が完成させた。

WebDAVには、元となるHTTP 1.1に加え次のメソッドが存在する。HTTPのヘッダ部でメソッドおよびURIを指定する。ボディ部では、クライアント・サーバ双方ともXMLを用いる。
Windows 98以降は「Webフォルダ」という名称のWebDAVクライアント機能を内蔵し、ネットワーク上に置かれたファイルとしてアクセスできる。
Windows XP SP2以降でBasic認証を行うには、HTTPS (SSL) での接続が必要であり、HTTP接続ではレジストリの設定を変更する必要がある。
Windows VistaではWebDAV機能は動作しない。「Web フォルダのソフトウェア更新プログラム: KB907306」を適用すれば32bit版に限り利用可能であったが、これも2022年現在は利用できない。
Windows 7以降は再び標準で利用可能となっている。
2023年11月にマイクロソフトからWebDAV機能は非推奨とされ、標準では利用不可となった。
その他、Windows用のクライアントとして、CarotDAVやNetDrive、TeamFileクライアントなどがある。
Finderは、WebDAVクライアント機能を内蔵している。Appleが運営するストレージサービスiDiskへのアクセスには、WebDAVを利用している。
GNOMEにおいてファイルアクセス抽象化機能を提供するGnomeVFSは、WebDAVクライアント機能を備えている。GNOMEのファイルなどファイルアクセスにGnomeVFSを用いているアプリケーションは、シームレスにWebDAVサーバ上のファイルにアクセスできる。
cadaverは、キャラクタユーザインタフェースを持つWebDAVクライアントである。
PerlにおけるHTTP::DAV、PythonのPyDAVなどのように、各種スクリプト言語向けのクライアントライブラリが複数存在する。
Subversionやarchでは、リモートリポジトリへのアクセスプロトコルにWebDAVが利用できる。
ハロウィーン文書内でのHTTP-DAVとは、WebDAVのことを指している。