| 通信プロトコル | |
| 開発者 | IETF |
|---|---|
| 導入 | 2015年5月14日 |
| 派生元 | SPDY |
| 派生先 | HTTP/3 |
| OSI階層 | アプリケーション層 |
| RFC | RFC 9113 |
| HTTP |
|---|
| 主要項目 |
| リクエストメソッド |
| ヘッダーフィールド |
| ステータスコード |
| 認証方式 |
| 脆弱性およびそれを利用した攻撃手法 |
HTTP/2 (Hypertext Transfer Protocol version 2) は、World Wide Webで用いられているHTTPのバージョンの一つである。
HTTP/2はIETFのHypertext Transfer Protocol Bis (httpbis)ワーキンググループにおいて制定され、2015年2月17日に正式な仕様として承認され、2015年5月に RFC 7540 として文書化された。HTTP/2はHTTP/1.1が1999年6月に RFC 2616 として規定されて以来16年ぶりのバージョンアップである。
HTTP/2の目標はHTTP/1.1のトランザクション・セマンティクスとの完全な後方互換性を維持したまま非同期な接続の多重化、ヘッダ圧縮、リクエストとレスポンスのパイプライン化を実現することである。Googleによって立ち上げられ、全ての主要なウェブブラウザが対応しているHTTP互換のプロトコルSPDYの人気が高まっていることに対応するために開発された。
下記の技術により従来より高速の通信を実現している。
下記ウェブブラウザが対応している。ただし、全てHTTP/2 over TLSのみである。
httpbisワーキンググループはGoogleのSPDYプロトコル、(SPDYを基にした)マイクロソフトのHTTP Speed+Mobility、Network-Friendly HTTP Upgradeを検討した。2012年7月にFacebookはそれぞれの提案にフィードバックを行い、HTTP/2はSPDYを基にすることを推奨した。SPDYをそのままコピーしたものを基にしたHTTP/2の最初のドラフトが2012年11月に発行された。
これらのプロトコルにおけるアーキテクチャ上の提案の多くは以前にW3CのHTTP-NGワーキンググループで調査済みであった。HTTP-NGプロジェクトの活動は1998年に休止された。
IETFのHypertext Transfer Protocol Bis (httpbis) ワーキンググループによる。
| 状態 | マイルストーン |
|---|---|
| 完了 | 最初のHTTP/1.1改訂版インターネットドラフト |
| 完了 | 最初のHTTPセキュリティプロパティインターネットドラフト |
| 完了 | HTTP/2.0のための提案の呼びかけ |
| 完了 | ワーキンググループによるHTTP/1.1のための最終案内 (Last Call) |
| 完了 | draft-mbelshe-httpbis-spdy-00を基にしたHTTP/2.0の最初のワーキンググループドラフト |
| 実施/延期 | ワーキンググループによるHTTPセキュリティプロパティのための最終案内 (Last Call) |
| 完了 | 標準化提案 (Proposed Standard) として検討されるためにIESGにHTTP/1.1改訂版を提出 |
| 完了 | ワーキンググループによるHTTP/2のための最終案内 (Last Call) |
| 2014年11月 | 標準化提案 (Proposed Standard) として検討されるためにIESGにHTTP/2を提出 |
| 2015年2月17日 | IETFにて仕様として承認され、RFCとしての文章化へと進む |
| 2015年5月14日 | RFC 7540として文書化 |
ワーキンググループにおいて当初はHTTP 2.0という名称で制定作業を進めていたが、後にHTTP/2と置き換えることとなった。また、GoogleはSPDY/4という呼び方もしていた[要出典]。